[Info] O bug do milênio

O bug foi corrigido!!!
Clique para baixar o SilentPatch que você nunca mais terá isso no seu GTA!



Resolvi fazer esse post já que muita gente não deu atenção ao do MixSets e continua me pedindo ajuda com isso.

É sobre um bug que atormenta muita gente: Artefatos na tela, piscando.
Pode ser corrigido diminuindo o uso de Stream Memory no jogo, abaixando para 512 ou 256 MB ou menos.


Os "soldados" já estão a caminho para descobrir e corrigir esse bug.

Clique aqui para ver o tópico na GTA Forums. Lá também tem scripts de testes caso você queira ajudar. Pode falar os resultados aqui nos comentários mesmo.


O estranho é que eu descobri que o problema não é realmente relacionado ao uso de memória do jogo, mas sim por quantidade de modelos.

Abaixo, um vídeo "provando" que o uso de memória não interfere totalmente (possivelmente interfere, mas por outro modos). E no fim do vídeo eu mostro de onde vem o bug.



-- Teste A
Pack de carros pesados = Não
Modelos carregados = 1 ao 10000
Uso de memória = 650 MB
Bug = Pernas e torso desaparecendo, constantemente, artefatos na tela são muito comuns. Geralmente azuis.

-- Teste B
Pack de carros pesados = Sim
Modelos carregados = 1 ao 612
Uso de memória = 1030 MB
Bug = Raramente, algumas vezes um pedestre sem perna mas ainda sem bug, dificilmente algum rápido artefato em 1 frame.



Como eu mostrei no vídeo, o bug vêm da renderização dos pedestres, geralmente pernas ou até mesmo do torso dele.

LINK/2012 verificou, e realmente causado pela renderização deles na placa de vídeo. Detalhes.

Fastman92 também concordou que PODE ser realmente causado depois de carregar muitos modelos e não necessariamente o alto uso de memória do jogo. É que na verdade, ao usar um alto limite de memória de streaming, realmente irá carregar mais modelos e realmente bugará...

Mas ninguém faz a mínima ideia, na verdade, tudo ainda é mistério e não podemos afirmar nada por completo, única coisa que podemos ter certeza é de que o bug vem da renderização dos pedestres, e possivelmente a causa é o grande número de carregamento de modelos. Mas o porquê de acontecer o bug é o grande mistério que precisa ser desvendado, e que os elites já estão à caminho procurando o problema.
Fastman92 disse que se descobrir o problema, virá na próxima versão do Fastman92 Limit Adjuster.

Se você quer participar nesta busca, faça qualquer teste, anotando os usos de memória, modelos carregados, tempo jogando, quais mods usando e tudo mais.
Também, como eu disse, no tópico há alguns scripts meus lá que você pode usar para testar (precisa de pelo menos um PC médio, e usar Open Limit Adjuster), além de mais informações.

Qualquer informação, diga aqui nos comentários, mas antes tenha realmente certeza disso.


O bug foi corrigido!!!
Clique para baixar o SilentPatch que você nunca mais terá isso no seu GTA!

Aviso:
Download quebrado?
Precisa atualizar?
Problemas com a postagem?
Indique mods para serem postados aqui (fórum) ou aqui (formulário).
Dê ideias de mods para GTA aqui.
É proibido discutir política, ideologias e religião aqui. Isto é um site de jogos, não facebook.
Devido à problemas com a regra acima e contas fakes, foi necessário ativar moderação. Seu comentário será aprovado dentro de 1 dia.
Abrir Comentários