Mais pequenas atualizações no Mix Sets

Pra não precisar subir o post, aqui o aviso de uma pequena correção que fiz no Mix Sets, mas também uma outra "correção" de um bug relatado por algumas pessoas recentemente.
(esta nova versão não precisa substituir o .ini, só o .cs já basta)



v2.1.4 (21/08/15)
  • Corrigida a função "NoVigMisWanted" (sem nível de procurado em missões da polícia), onde quando você estava sendo procurado, entrava num carro e ligava a missão, perdia todas as estrelas, então agora este fix não se ativará mais caso você já esteja sendo procurado.
  • O MixSets a partir de hoje virá também com o "StreamMemoryMB" configurado para 512 MB ao invés de 1024, pois o GTA SA tem um bug ao usar muita memória, onde aparece artefatos piscando no mapa (clique aqui para ver), então é recomendado usar 512 MB ou até menos. Se você não tem este problema, pode continuar com "StreamMemoryMB = 1024" ou mais.
  • Os comandos do Anti-Aliasing foram trocados, para evitar conflitos de comandos.

Um autodidata polímata. Amante de computação, música, desenvolvimentos e ciências em geral. Ibitinga - SP

Veja também

Próximo
« Anterior
Anterior
Próximo »
Nota: Envie sugestões de postagens neste link. Caso problemas, use a Lista de Crash.
36 Comentários


Foi removido os comentários pelo sistema do blogger. Por favor, use o Disqus.


36 comentários:
Israel de Jesus

Deixo o StreamMemoryMB = 1024, mas nunca tive problema algum, ainda bem.

Zera

Infelizmente, 512mb ainda causa o bug. Qualquer valor acima de 100mb vai causar o bug mais cedo ou mais tarde (já fiz vários testes nisso). Mas se vc não gosta de voar nos aviões ou helicópteros, é possível que nunca verá o bug.

Junior_Djjr

q pena, pelo menos 512 MB jah resolve muito, e resolveu o problema da Firefly com o pack dela (incluindo q essa print eh dela) e de mais outro cara tbm

meu gta (msm sem mods de textura, carro etc) sempre anda acima de 100 MBe jah cheguei até passar de 512, inclusive 1 GB (num teste q fiz usando um cleo pra carregar tudo) e sempre tudo ok :v

Zera

Pois é, 100mb não é sufficiente nem pro jogo sem modificações nas texturas (dá os "buracos" no mapa quando tá voando). Mas acontece no meu laptop e no meu PC, então não acho que seja hardware (um é placa AMD e o outro é Nvidia).

Junior_Djjr

vc veh esse problema jah há quanto tempo?

antigamente (meio ano?) eu vi UMA pessoa aqui com esse problema, e na ultima semana eu vi QUATRO
tem alguma coisa errada, algum mod famoso q saiu ultimamente aumentou o problema acho

Junior_Djjr

ah, esse bug tbm jah foi solucionado ao remover a ENB Series

Dinho Rodrigues

eu tambem to com esse ploblema acho q e o (SRt3 Mipmap 2014)

Jhonatan Paiva

por isso meu gta ficava piscando inexplicavelmente

JOGOS PC

2024 deu uns 10 fps aki mais pelo que eu vi tem um pouco de memory leak, 1024 ainda continua sendo uma boa opção.

Gabriel Santos

"O MixSets a partir de hoje virá também com o "StreamMemoryMB" configurado para 512 MB ao invés de 1024, pois o GTA SA tem um bug ao usar muita memória, onde aparece artefatos piscando no mapa (clique aqui para ver), então é recomendado usar 512 MB. Se você não tem este problema, pode continuar com "StreamMemoryMB = 1024" ou mais."
EU SOU FÃ DE VCS AI DA MIX !!
ADEUS BUG CHATO !!

Zera

Não uso ENB. Quando isso aconteceu comigo pela primeira vez (uns dois anos atrás, eu acho?), eu só estava usando o WidescreenFix com o Project2DFX e alguns plugins do Ryosuke (e o memfix em cleo, claro). Ficou o jogo inteiro sem dar o bug, só deu quando eu fiz as corridas aéreas de Las Venturas (em que vc fica muito tempo voando por várias partes do mapa, então o uso da memória vai lá em cima).

Thiago Rodriguez ᴴᴰ

continua não pegando no samp

Thiago Rodriguez ᴴᴰ

Junior, to um tempo querendo falar cntg, ia pedir um trabalho seu, disposto até a pagar! é algo simples creio que pra vc seja muito simples, entrei em contato contigo no face, mesmo nome, responda quando puder, realmente preciso

softwares- BR

Alexandre:
jesusssssss maria José, até que em fim alguém convenceu vcs que o "Memory1 e 2 GB tem problemas "pode não ser eles mais usá-los causa prob", na época eu cansei mais cansei de fala gente tem prob sim pois meu pc é muito forte e causa na época falei bug de ficar piscando "Esse bug ai" e a de 512 não da isso, nossa riram e tudo, sabe qual é é menosprezar as opiniões das pessoas leigas, quando se acha o fod@,

bom para não ficar só com eu tava com razão porr@, vamos lá...
Não não tem nada haver com enb, já fiz inúmeros testes sem e deu a msm coisa, não é somente usar mod de carros etc que causa isso, tb já fiz esse teste carros originais já tive esse prob, e o maior mod que mais causa esse bug é o mod de "_Lod_Mod" msm que coloque para não visualizar muita a distancia, diminui mais não elimina o bug, bom hj meu gta ta todo mudado sim tenho mod de lod... mais utilizo 512 de mem... e o "limit_adjuster_gta3vcsa" nessa conf aonde para mim repito para mim resolveu, dificilmente aparece esse bug agora, bom fiz minha parte espero que novamente não ignoraram os leigos em mod, pois vcs criam mais quem realmente testa somos nós os "usuários"

"512 mem"
"limit_adjuster_gta3vcsa"

[SALIMITS] // 0x550F10
PtrNodeSingle = 170000
PtrNodeDouble = 9200
EntryInfoNode = 500
Peds = 140
Vehicles = 110
Buildings = 22000
Objects = 3500
Dummys = 9500
ColModel = 10500
Task = 500
Event = 200
PointRoute = 64
PatrolRoute = 32
NodeRoute = 64
TaskAllocator = 16
PedIntelligence = 140
PedAttractors = 64
StaticMatrices=99999

[VCLIMITS] // 0x4C0270
PtrNode = 70000
EntryInfoNode = 3200
Peds = 140
Vehicles = 110
Buildings = 20000
Treadables = 1
Objects = 3500
Dummys = 9500
AudioScriptObj = 192
ColModel = 10500

[GTA3LIMITS] // 0x4A1770
PtrNode = 90000
EntryInfoNode = 25400
Peds = 140
Vehicles = 110
Buildings = 35500
Objects = 9500
Dummys = 22802

softwares- BR

Alexandre:
a e esqueci de falar, por algum motivo o mixsets causava tb msm desabilitando tudo, não sei por q se ta tudo desabilitado tive que usar e a principal coisa que dava comigo usando o mix... é em aleatoriamente as vezes os pedestres sumiam a metade só encostando ai ficava normal, nossa cansei de testa desabilitava tudo e causava do msm mod por fim cansei e tirei o mod querendo usar por outras funções, mais esse bug me tirava a calma, existe a possibilidade de msm desabilitado um mod acabar lido depois desabilitado pelo jogo, " ficou estranho né" tipo sei lá ex, mod de ped ser visto a dist..., o jogo ler o mod mais como ta desab ele ler e desabilita, ou desabilitado o mod fica fora da leitura do jogo?, deu para entender ai né?, fuiiii

Junior_Djjr

caramba, oq vc eh do Sandro? vcs dois reclamam demais, gzuz
aposto q são irmãos ou amigos de infância, igualzinho

Junior_Djjr

vc está enganado, se está tudo desativado, absolutamente nada será ativado

"ain, maix eu testei, eu cei oq to falando"

mas foi eu q criei o mod....

o mod eh 100% criado em condições, não há como alguma coisa se ativar caso ela esteja desativada

veja uma parte de como funciona a leitura do .ini:

(.....)
if and
0AF0: 0@ = get_int_from_ini_file "cleo\Mix Sets.ini" section "Sets" key "DisableHeat"
0@ == true
then
0A8C: write_memory 0x72C1B7 size 1 value 0xEB vp 1
end

if and
0AF0: 0@ = get_int_from_ini_file "cleo\Mix Sets.ini" section "Sets" key "DisaPedDinaSha"
0@ == true
then
0A8C: write_memory 0x5E6766 size 2 value 0x9090 vp 1
end

if and
0AF0: 0@ = get_int_from_ini_file "cleo\Mix Sets.ini" section "Sets" key "DisaWldDinaSha"
0@ == true
then
0A8C: write_memory 0x7113C0 size 1 value 0xEB vp 1
end

if and
0AF0: 0@ = get_int_from_ini_file "cleo\Mix Sets.ini" section "Sets" key "LicTextFilter"
0@ > 0
then
0A8C: write_memory 0x884958 size 1 value 0@ vp 1
end

if and
0AF0: 0@ = get_int_from_ini_file "cleo\Mix Sets.ini" section "Sets" key "TexFiltMIN"
0@ > 0
then
0A8C: write_memory 0x88498c size 1 value 0@ vp 1
end

if and
0AF0: 0@ = get_int_from_ini_file "cleo\Mix Sets.ini" section "Sets" key "TexFiltMAX"
0@ > 0
then
0A8C: write_memory 0x884988 size 1 value 0@ vp 1
end

if 0AF2: 0@ = get_float_from_ini_file "cleo\Mix Sets.ini" section "Sets" key "SpecDirX"
then
0A8C: write_memory 0xB7CB14 size 4 value 0@ vp 1
end

if 0AF2: 0@ = get_float_from_ini_file "cleo\Mix Sets.ini" section "Sets" key "SpecDirY"
then
0A8C: write_memory 0xB7CB18 size 4 value 0@ vp 1
end

if 0AF2: 0@ = get_float_from_ini_file "cleo\Mix Sets.ini" section "Sets" key "SpecDirZ"
then
0A8C: write_memory 0xB7CB1C size 4 value 0@ vp 1
end
(....)

Junior_Djjr

pagar, sei :v

Junior_Djjr

........
e cade log? e cade q vc desativou as funções para procurar qual eh? tah tudo escrito, vc soh chegar aqui e falar "nao funciona" nao irá ajudar em absolutamente nada

Junior_Djjr

sim, eh o alto uso de memória, e saporra aumenta muitíssimo a memória

Junior_Djjr

2 GB
"pouco de memory leak" kkkkkkk

soh GTA V pra usar 2 GB de RAM, oq tem ai eh puro memory leak, isso sim kkk

Kaede Monthmore (reserva)

Mimimi, 1024 dá bug... Botem em 1023 que fica de boa!


Sério mesmo, eu achava que era o modloader e até perguntei nos comments de lá, só que um dia pus memória em 1023 de zoeira com um amigo meu e parou. Vai entender...

SharingaN NTKO

Não entendi? é até compreensivel que vc ache estranho pq vcs modders fazem um trabalho voluntario praticamente, pra um monte de pessoas admirar e jogar melhr, eu preciso de algo especifico e nao vejo problema nenhum em ajudar com alguma grana se meu pedido fosse atendido ja que gasto com o samp regularmente, tenta entrar em contato

softwares- BR

Sandro? não entendi, cara apenas falei que eu sempre reclamei pedi ajuda e tal aqui e fui ignorado, existe algum mal nisso? eu q não te entendo velho, + deixa rolar...

softwares- BR

igual aqui, te fiz uma pergunta comece isso ? no fim de uma frase é uma pergunta e não dando a certeza de algo dito, deixa rolar...

é ta de boa já entendi...

Dinho Rodrigues

eu diminui a memora para 512 MB e resolveu aq vlw

Dinho Rodrigues

kkkkkkkkkkkkkkk

Junior_Djjr

1023 kkkkkkkkk

mas tipo, nao faz sentido o máximo e sim o atual uso, o limite nao mudará o funcionamento do jogo caso vc nunca chegar no limite

o bug pode aparecer em qualquer uso acima doq o limite original do jogo proporciona, como o Zera disse

"Zera15/9/15 13:28
Pois é, 100mb não é sufficiente nem pro jogo sem modificações nas texturas (dá os "buracos" no mapa quando tá voando). Mas acontece no meu laptop e no meu PC, então não acho que seja hardware (um é placa AMD e o outro é Nvidia)."

Junior_Djjr

eh q vc eh igual o seu "parceiro" :v

Junior_Djjr

entao tah, me chame lah

Keven Roger da Silva

Hue O mix sets meio q bugo meu GTA, eu baixei a nova versão. não essa mas a anterior ( ou anterior da anterior). O GTA fica com delay, tipo se eu aperto pra andar depois de 10 seg ele anda kkkk. isso no jogo todo. Como faz para olhar que versão to usando? . pq eu deleto o arquivo quando instalo um mod. dai daria pra saber oque foi adicionado que ta dando esse "bug". a versão não atual que to usando não da esse delay.

Junior_Djjr

me envie o arquivo .cs

Keven Roger da Silva

http://www.4shared.com/file/uex3b2yjce/Mix_Sets__Junior_Djjr_.html
Tive que enviar pelo 4shared, o Dropbox demora 10h para abrir aqui, net discada do cao. kk

Junior_Djjr

demorar esse tempo nao eh normal, eu msm antigamente usava 4shared e parei de usá-lo pra começar a usar dropbox exatamente pq eu tinha net ruim e demorava pra abrir o 4shared, dae o dropbox abria em poucos segundos, jah q nao precisa carregar nada, eh soh logar, então abre numa boa até se a net estiver 30 kbps, tem coisa errada ai

----------
oq vc mandou eh uma versão antes de colocar a função ProcessPriority, tem ctz q tah "ProcessPriority = 4" lah no .ini? tente colocar 3, ou 2, ou desativar

Paulinho S.

quando chego em 520 da aquele bug de coisas piscando.
eu coloquei em 420 foi normal, depois de um tempinho jogando ele trava ok.
coloquei a 1024 e quando chegou nos 850 de memória do jogo ele deu os pisca dnv kkkk.

junior eu devo colocar em 520 quando eu tiver muitos mods neh?
eu não costumo colocar muitos carros e evito de vegetação pesadas

Junior_Djjr

Mas 420 não ficou bom? Se tah bom, tah bom, se todo o mapa carregou normal etc tah bom jah